Questões

Total de Questões Encontradas: 05

Servlets são classes Java utilizadas em aplicações web. Sobre elas, considere:

I. Herdam a classe HttpServlet e implementam as classes HttpServletRequest e HttpServletResponse.
II. Em aplicações que utilizam o padrão Model-View-Controller, são representadas no grupo Controller.
III. Normalmente possuem métodos para receber requisições que foram enviadas utilizando os métodos HTTP Get e Post.
IV. Utilizam classes dos pacotes javax.servlet, javax.swing e java.io.

Está correta o que se afirma somente em:
A
I e III.
B
II e IV.
C
II.
D
III.
E
II e III.
Considere a utilização dos navegadores Internet Explorer ou Google Chrome. Utilizando CSS3, para aplicar ao fundo de um contêiner (criado com a tag div) um efeito gradiente linear no sentido de cima para baixo, começando vermelho e terminando azul, utiliza-se a instrução:
A
background: linear-gradient(red, blue);
B
background: top-to-bottom(red, blue);
C
background-color: top-to-bottom(red, blue);
D
background-gradient: top-to-bottom(red, blue);
E
background-linear-gradient: top-to-bottom(red, blue);
Texto Associado Texto Associado
ATENÇÃO: O pseudocódigo a seguir deverá ser utilizado para responder às questões 43 e 44.

algoritmo Teste001
var y, x, cont1, cont2, e, r: inteiro
início
      leia(y, x)
      r <x
      para cont1 <2 até y passo 2
            e <x
            cont2 <1
            para cont2 <1 até cont1 - 1 passo 1
            fim_para
            r <r + e
      fim_para
      imprima(r)
fim
Em java, a instrução para cont1 <2 até y passo 2 deverá ser escrita como:
A
for (cont1 = 2; cont1 < y; cont1 = cont1 + 2) {
B
for (cont1 = 2; cont1 <= y; cont1 += 2) {
C
for (int cont1=2; cont1 <= y; cont1 += cont1 + 2) {
D
for (cont1 = 2, cont1 <= y; cont1 = cont1 + 2) {
E
for (cont1 == 2; cont1 <= y; cont1 +== 2) {
Texto Associado Texto Associado
ATENÇÃO: O pseudocódigo a seguir deverá ser utilizado para responder às questões 43 e 44.

algoritmo Teste001
var y, x, cont1, cont2, e, r: inteiro
início
      leia(y, x)
      r <x
      para cont1 <2 até y passo 2
            e <x
            cont2 <1
            para cont2 <1 até cont1 - 1 passo 1
            fim_para
            r <r + e
      fim_para
      imprima(r)
fim
Se forem lidos os valores 6 para y e 2 para x, será impresso o valor:
A
22
B
4372
C
86
D
276
E
20
Quando o desenvolvimento de sistemas não leva em consideração técnicas e recursos para prover segurança no desenvolvimento, pode haver várias consequências, inclusive perdas financeiras decorrentes das falhas. Com relação à programação segura em sistemas orientados a objetos, analise as asserções a seguir.

Em sistemas orientados a objeto, os objetos são encapsulados, o que os protege, restringindo o acesso ao seu conteúdo.

PORQUE

os valores armazenados em atributos nos objetos só podem ser acessados por meio do próprio objeto, de forma que nenhum objeto seja capaz de acessar dados internos de outro objeto.

Acerca dessas asserções, é correto afirmar que:
A
as duas asserções são proposições verdadeiras, mas a segunda não é a justificativa correta da primeira.
B
as duas asserções são proposições verdadeiras, e a segunda é a justificativa correta da primeira.
C
a primeira asserção é uma proposição falsa, e a segunda, uma proposição verdadeira.
D
a primeira asserção é uma proposição verdadeira, e a segunda, uma proposição falsa.
E
tanto a primeira quanto a segunda asserções são proposições falsas.
Página 1 de 1