Questões

Total de Questões Encontradas: 139

Texto Associado Texto Associado
Imagem Associada da Questão
Considerando o algoritmo fornecido, o valor da variável z ao final da execução do programa é:
A
2
B
4
C
6
D
9
E
12
Ano: 2013 Banca: VUNESP Órgão: COREN-SP Prova: Analista - Sistemas
Texto Associado Texto Associado
Imagem Associada da Questão
No caso de a1 e a2 serem iguais, considerando ainda b=7, o número de vezes que o bloco “Senão” será executado é
A
B
C
D
4
E
6
Ano: 2013 Banca: VUNESP Órgão: COREN-SP Prova: Analista - Sistemas
Texto Associado Texto Associado
Imagem Associada da Questão
Considerando o algoritmo apresentado, ao final de sua execução, o valor de x impresso será
A
B
C
12 
D
18 
E
24
Texto Associado Texto Associado
ATENÇÃO: O pseudocódigo a seguir deverá ser utilizado para responder às questões 43 e 44.

algoritmo Teste001
var y, x, cont1, cont2, e, r: inteiro
início
      leia(y, x)
      r <x
      para cont1 <2 até y passo 2
            e <x
            cont2 <1
            para cont2 <1 até cont1 - 1 passo 1
            fim_para
            r <r + e
      fim_para
      imprima(r)
fim
Em java, a instrução para cont1 <2 até y passo 2 deverá ser escrita como:
A
for (cont1 = 2; cont1 < y; cont1 = cont1 + 2) {
B
for (cont1 = 2; cont1 <= y; cont1 += 2) {
C
for (int cont1=2; cont1 <= y; cont1 += cont1 + 2) {
D
for (cont1 = 2, cont1 <= y; cont1 = cont1 + 2) {
E
for (cont1 == 2; cont1 <= y; cont1 +== 2) {
Texto Associado Texto Associado
ATENÇÃO: O pseudocódigo a seguir deverá ser utilizado para responder às questões 43 e 44.

algoritmo Teste001
var y, x, cont1, cont2, e, r: inteiro
início
      leia(y, x)
      r <x
      para cont1 <2 até y passo 2
            e <x
            cont2 <1
            para cont2 <1 até cont1 - 1 passo 1
            fim_para
            r <r + e
      fim_para
      imprima(r)
fim
Se forem lidos os valores 6 para y e 2 para x, será impresso o valor:
A
22
B
4372
C
86
D
276
E
20
Ano: 2014 Banca: CESGRANRIO Órgão: PETROBRAS Prova: Técnico - Técnico de Informática
Considere a situação abaixo. 
Imagem da Questão
Qual é a saída do algoritmo faca_contas para a entrada  7, 3, 5, 2, 3 ?
A
3
B
C
7
D
10
E
12
Ano: 2014 Banca: VUNESP Órgão: DESENVOLVESP Prova: Analista - Analista de Sistemas
Texto Associado Texto Associado
Imagem Associada da Questão
Suponha que o método “print” seja alterado para:

public static void print(String s){
     System.out.print(s);
     if (s.length() % 2 != 0) {
          System.exit(1);
     }
}

Como efeito dessa alteração,
A
nada acontecerá, pois nenhum parâmetro fará com que a condição testada seja verdadeira.
B
um erro de compilação será produzido, pois o programa não pode ser encerrado por um método estático.
C
uma exceção será produzida em tempo de execução devido ao parâmetro passado ao método “exit”.
D
o programa terminará após a segunda chamada ao método “print”.
E
o programa terminará após imprimir qualquer mensagem cujo tamanho seja ímpar.
Ano: 2014 Banca: VUNESP Órgão: DESENVOLVESP Prova: Analista - Analista de Sistemas
Texto Associado Texto Associado
Imagem Associada da Questão
Ao se executar esse código em um terminal, será produzida a mensagem:
A
Quem não tem cão caça com gato.
B
Quem não tem cão faz omelete.
C
Quem não tem gato caça com omelete. 
D
Quem não tem não cão faz caça com faz omelete.
E
Quem não tem não gato faz caça com faz gato.
Ano: 2014 Banca: VUNESP Órgão: DESENVOLVESP Prova: Analista - Analista de Sistemas
Texto Associado Texto Associado
Imagem Associada da Questão
Ao final da execução do programa, o valor impresso de g4 será: 
A
0
B
3
C
7
D
9
E
10
Ano: 2014 Banca: VUNESP Órgão: DESENVOLVESP Prova: Analista - Analista de Sistemas
Texto Associado Texto Associado
Imagem Associada da Questão
O número de iterações que o comando Para... irá executar no programa apresentado é igual a: 
A
3
B
4
C
5
D
6
E
7
Página 6 de 14